Posted by Rich on August 14, 2013 at 03:59 PM CST
We're receiving reports that the first batch of Slave I vehicles shipped from Amazon continue to arrive in unprotected, damaged boxes. Readers are writing in to let us know that getting a replacement has been easy thanks to Amazon's friendly customer service, but it's come to our attention there may be another problem.

According to Rebelscum reader Will Melay, a number of Slave I vehicles are arriving with several missing parts, and Amazon customer service is calling the issue widespread. Whats worse is the Slave I is now showing as currently unavailable on Amazon.com and refunds are being offered in lieu of exchanges. We've contacted Amazon for an official response, but in the meantime if your Slave I is missing parts, a call to Hasbro customer service at 1-800-255-5516 to inquire about replacements might be worth a try.
Related Articles
September 3, 2013  Hasbro: Amazon Exclusive Slave I Found At Discount Stores!
August 15, 2013  Slave I Update
comments powered by Disqus

San Diego Comic-Con 2014
More News at TheForce.net
There was an error retrieving the news feed
NEW IN THE PHOTO ARCHIVE:
Probe
Droid
Poll
While it can be argued that both are important to many collectors, the Probe Droid wants to know, if given the choice, would you demand Hasbro brought back all the articulation or improve the paint applications.
Great Paint applications are more important to me.
I'm all about multiple poses, so I'd rather see all the articulation come back.
Current Results